Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: wcb4xxp/NewFeature
    • Labels:
      None
    • Mantis ID:
      13897
    • Regression:
      No

      Description

      A patch to add some basic support of other HFC-4S -based PCI cards (such as the ones made by Junghanns).

      Status: gets rid of the echo canceller messages when not needed, but still needs work.

      Specifically:

      • It adds too broad a range of cards (which also include bero.net cards)
      • The range may include some 2-ports cards, which will probably not work.

      Not yet tested to work, though it it is at least configured.

      1. base.c.patch
        8 kB
        odicha
      2. base.c.V2.patch
        8 kB
        odicha
      3. dahdi_tools.diff
        1 kB
        odicha
      4. dahdi-linux-2.1.0.4.diff
        19 kB
        odicha
      5. dahdi-tools-2.1.0.2.diff
        2 kB
        odicha
      6. hfc4s.diff
        3 kB
        Tzafrir Cohen
      7. HFC-8S.diff
        17 kB
        odicha
      8. patch_b400P
        8 kB
      9. patch_b400P_2.diff
        9 kB
        Tzafrir Cohen
      10. wcb4xxp_b4_variety.diff
        10 kB
        odicha
      11. wcb4xxp_extra_cards_dahdi-tools.diff
        2 kB
        odicha
      12. wcb4xxp_extracards_2.diff
        17 kB
        Tzafrir Cohen
      13. wcb4xxp_extracards_leds_fixes.diff
        17 kB
        odicha
      14. wcb4xxp_extracards.diff
        17 kB
        Tzafrir Cohen
      15. wcb4xxp_v5.diff
        13 kB
        odicha
      16. wcb4xxp.diff
        3 kB
        Jean-Denis Girard
      17. wcb4xxp.h.patch
        0.4 kB
        odicha

        Activity

        M. Schinkel added a comment -

        @heruan:

        I'm not a pci expert but imho integrated controllers matter if they are on the same bus and there is no bridge between them

        xelinaf added a comment -

        @heruan:
        For myself I had a problem with my host bridge having a latency of 128 and an HFC-S chip. All other cards have a latency of 32 or less. Since I changed the latency to 16, everything works fine.

        Just give it a try and set all latencies >32 to 32 or 16, i.e.:
        setpci -vv -s 00:0b latency_timer=10
        setpci -vv -s 00:0c latency_timer=10
        setpci -vv -s 00:0d latency_timer=10
        setpci -vv -s 00:13 latency_timer=10
        setpci -vv -s 05:00 latency_timer=10

        BTW: I've got the same error message as you got with my HFC-4S card.
        I've got two devices with a latency of 248. But unfortunately I cannot modify the PCI latency for these 2 devices on my board.
        Thus I cannot check myself, if the pci latency is the cause of our problem.

        Giovanni Lovato added a comment -

        Thank you, I'll try as soon as possibile this latencies trick.
        But I don't understand why with zaptel and qozap it worked perfectly and now we need to hack those values... Maybe it's just a temporary workaround? Will the next dahdi release support this card better?

        nenadr added a comment -

        I can confirm that this patch is wotking OK with both OpenVox B400P (PCI) and B400M (miniPCI) card (including LEDs), except in part that is not "treated" by this patch (take a look at the notes of bug# 0014031 (https://issues.asterisk.org/view.php?id=14031 )).

        Digium Subversion added a comment -

        Repository: dahdi
        Revision: 6822

        U tools/trunk/xpp/perl_modules/Dahdi/Hardware/PCI.pm

        ------------------------------------------------------------------------
        r6822 | tzafrir | 2009-07-02 15:35:36 -0500 (Thu, 02 Jul 2009) | 19 lines

        Officially declare we support all HFC-xS cards.

        (closes issue DAHLIN-59)
        Reported by: tzafrir
        Patches:
        wcb4xxp_extra_cards_dahdi-tools.diff uploaded by Odicha (license 700)

        The main fix is in commits the following commits to dahdi-linux:
        r6812, r6813, r6814, r6815, r6816, r6817, r6818 and r6821

        Those include the contents of:

        wcb4xxp_extracards_leds_fixes.diff uploaded by Odicha (license 700)

        Tested by: zhulizhong, jdg, tzafrir, okrief, Odicha, opticron, vrban

        Many thanks for all the testing, patches and feedback from this issue.

        ------------------------------------------------------------------------

        http://svn.digium.com/view/dahdi?view=rev&revision=6822


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development