DAHDI-Tools
  1. DAHDI-Tools
  2. DAHTOOL-31

[patch] dahdi-tools installes files under /etc/modprobe.d without a .conf extension

    Details

    • Type: Bug Bug
    • Status: Closed
    • Severity: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Target Release Version/s: None
    • Component/s: General
    • Labels:
      None
    • Mantis ID:
      15454
    • Regression:
      No

      Description

      Latest versions of udev at some distributions (e.g.: Debian Unstable/Testing) complain about the files /etc/modprobe.d/dahdi and /etc/modprobe.d/dahdi-blacklist . This is because some upcoming version of udev will ignore files in modprobe.d that are not of the pattern *.conf .

      (TODO: include here the relevant warning)

      Attached a simple patch to install our files as .conf .

        Activity

        Itamar Reis Peixoto added a comment -

        this is for dahdi-linux.

        Itamar Reis Peixoto added a comment -

        it's not only in debian, in fedora too.

        https://bugzilla.redhat.com/show_bug.cgi?id=495453

        Itamar Reis Peixoto added a comment -

        Can you apply this patch ?

        Digium Subversion added a comment -

        Repository: dahdi
        Revision: 8161

        U tools/trunk/Makefile

        ------------------------------------------------------------------------
        r8161 | sruffell | 2010-03-01 11:33:02 -0600 (Mon, 01 Mar 2010) | 11 lines

        Add .conf extensions to files installed in /etc/modprobe.d/

        Latest versions of udev at some distributions (e.g.: Debian Unstable/Testing)
        complain about the files /etc/modprobe.d/dahdi and
        /etc/modprobe.d/dahdi-blacklist . This is because some upcoming version of udev
        will ignore files in modprobe.d that are not of the pattern *.conf.

        (closes issue DAHTOOL-31)
        Reported by: tzafrir
        Patches:
        modprobe_warn.diff uploaded by tzafrir (license 46)
        ------------------------------------------------------------------------

        http://svn.digium.com/view/dahdi?view=rev&revision=8161


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development