Details

    • Type: New Feature New Feature
    • Status: Closed
    • Severity: Major Major
    • Resolution: Fixed
    • Component/s: Utilities
    • Labels:
      None
    • SVN Revision Number:
      2289
    • Mantis ID:
      8239
    • Regression:
      No

      Description

      As I find myself writing to complex a logic in init.d scripts, I figured out it it needs to be put in a separate binary. I attach a simple shell script that implements most of the logic of the Debian init.d script I currently have.

      The idea is that distributions/integrators will have an easy-to-use and well-tested set of scripts.

      A very raw and simple version to help discussions.

        Activity

        Joshua Colp added a comment -

        Did you want to discuss it on here or did you mean in a general sense that is what the file is for?

        Tzafrir Cohen added a comment -

        Focusing on zaptel/team/tzafrir/zaphelper instead of this attachment.

        Tzafrir Cohen added a comment -

        Still about zero comments her and in the list, and no sign of this code getting merged any time soon.

        Here are some of the bugs that this code solves:

        1. if you use ztd-loc, you have to explicitly set MODULES to include ztdynamic, and before zdt-loc . Ditto for ztd-eth.

        2. If you use the Xorcom Astribank, things are even worse: you have to know that the load order should be 'xpp xpd_fxs xpd_fxo xpp_usb' or another holy string. Even though you don't really need to the init.d script to actually load your module: it normally loads using the system's hotplug/coldplug init scripts.

        However if you fail that magic string, the modules unloading will fail.

        3. Module load seems to fail, when the only problem is an improperly-written zaptel.conf

        4. WC[2]400P cards are not getting tuned because fxotune is not getting called at boot time.

        5. Unnecesary sleep-s at system startup delay system boot.

        I bet there are others. But those will do.

        Serge Vecher added a comment -

        tzafrir: why is Disclaimer field set to "no"?

        Tzafrir Cohen added a comment -

        Thanks for the note. Originally I have left the default as no as I had no attachement.

        The attachemnt here is disclaimed (just to clarify things).
        anyway I have already commited those changes to a branch of the repository:

        http://svn.digium.com/svn/zaptel/team/tzafrir/zaphelper

        so they are already availble in a safely-disclaimed way.

        Serge Vecher added a comment -

        jsmith, MatsK: any feedback on the patches?

        seb7 added a comment -

        The patch that has been already attached is only part of tzafrir's solution as you can see from his zaptel branch.

        How does one test the branch? Just check it out like checking out zaptel?

        Tzafrir Cohen added a comment -

        Most recent version of zaptel-helper can now be found in xpp/zaptel/utils (currently in 1.2 and 1.4, and soon in trunk). It is still not installed automatically, though.

        I have fixed a number of errors in it since.

        Jason Parker added a comment -

        Since this is committed, I'm going to go ahead and close this.

        Please reopen if I'm incorrect..


          People

          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development